[Prelude-LML] Invalid section : "Pcre"

Added by yasey omal almost 6 years ago

I'm running Prelude 4.1.0 on Ubuntu 17.04.
I have setup and built the prelude-lml installation. When I run make check command it triggered some errors. I'm bit confused whether it is related to the regression tests.

Making check in tests
make[1]: Entering directory '/root/prelude-lml/tests'
./ ../plugins/pcre/ruleset/*.rules | ../src/prelude-lml --quiet --dry-run --metadata=nowrite,head --batch-mode --no-resolve --pcre --dump-unmatched --config ./prelude-lml.conf 2>&1 | /bin/grep -Fvf ./ignored
Invalid option -- "pcre" (0).
Invalid option -- "dump-unmatched" (0).
./prelude-lml.conf:52: invalid section : "Pcre".
./prelude-lml.conf:53: invalid option "ruleset" in "global" section.
04 Aug 18:54:13 (process:18979) ERROR: couldn't open config file /usr/local/etc/prelude-lml/plugins.rules. (regex.c:168 get_regex_table)
04 Aug 18:54:13 (process:18979) WARNING: error while setting option 'file'.
Traceback (most recent call last):
  File "./", line 6, in <module>
    f = open(filename, "r")
IOError: [Errno 2] No such file or directory: '../plugins/pcre/ruleset/*.rules'