Project

General

Profile

[Solved] barnyard compilation for prelude

Added by Thierno DIOP almost 7 years ago

I tried to compile barnyard2-1.9 and I got this message:

checking for libprelude - version >= 0.9.6... no
  • Could not run libprelude test program, checking why...
  • The test program failed to compile or link. See the file config.log for the
  • exact error that occured. This usually means LIBPRELUDE was incorrectly installed
  • or that you have moved LIBPRELUDE since it was installed. In the latter case, you
  • may want to edit the libprelude-config script: /usr/bin/libprelude-config
    checking for linuxthreads... no
    configure: creating ./config.status

So I installed the last version of libprelude and libprelude-devel correctly with yum install.
Please how to solve this problem??

Regards


Replies (5)

RE: barnyard compilation for prelude - Added by Antoine LUONG almost 7 years ago

Hello,

Did you install the libtool-ltdl-devel package?

Regards

RE: barnyard compilation for prelude - Added by Thierno DIOP almost 7 years ago

Hello,

Antoine,thanks for answering me.
Finally i reconfigured all my config and now snort and barnyard2 start well.
So my problem is snort can't capture the traffic. Please following my output
files after starting. I believe that there is no error.

Regards

snort.png View (114 KB)

barnyard2.png View (58.7 KB)

RE: barnyard compilation for prelude - Added by Antoine LUONG almost 7 years ago

Did you follow the wiki instructions?
If the problem remains, please contact Snort support.

RE: barnyard compilation for prelude - Added by Thierno DIOP almost 7 years ago

Yes I followed the wiki instructions. Now I can capture snort traffic in /var/log/snort/alert.
Also I connected snort and barnyard2. On prewikka, I see snort connected.
So I ask how I can do to see snort alerts on my prewikka interface?

    (1-5/5)