Project

General

Profile

[prewikka] Multiple options not avaibale after installing prewikka

Added by Steven Shawn 3 months ago

I have finally installed a clean prelude infrastructure (libprelude, libpreludedb, prelude-manager and prelude-correlator). The basic use cases are working, all the alerts being generated by my sensors are correctly forked to the prelude-manager and consequently to the prelude-correlator.

The next step was to install prewikka to be able to see the alerts and monitoring the actives. After installing prewikka (with no visible errors) and accesing to the web interface (no password requested) I can't barely do nothing in prewika, all the options seems to be blocked (as shown in the image attached). I just can access to ADMIN -> Preferences and "?" sections. At the ADMIN->Preferences sections it says that my Login is "anonymous" but I don't know how to change that if it doesn't requested me the password. Furthermore, if I go to the Apps section, all the apps seems to be enabled but I cannot access to any prewikka option.

Anybody knows what is the problem/missing?

Thank you

Steven

prewikka_1.png View (59.3 KB)


Replies (6)

RE: [prewikka] Multiple options not avaibale after installing prewikka - Added by Steven Shawn 3 months ago

I've already solved the exclamation symbols that can bee seen in the image attached for the IDMEF Alert Plugin and IDMEF Heartbeat Plugin Apps. But I still have the same problems.

RE: [prewikka] Multiple options not avaibale after installing prewikka - Added by Steven Shawn 3 months ago

I've been taking a look at the data base that prewikka uses:


mysql> show tables;
+-----------------------------+
| Tables_in_prewikka          |
+-----------------------------+
| Prewikka_Crontab            |
| Prewikka_Filter             |
| Prewikka_Filter_Criterion   |
| Prewikka_History_Query      |
| Prewikka_Module_Changed     |
| Prewikka_Module_Registry    |
| Prewikka_Permission         |
| Prewikka_Session            |
| Prewikka_User               |
| Prewikka_User_Configuration |
| Prewikka_Version            |
+-----------------------------+

In the Permission table, only the admin user has rights to do things:

+-------+-------------------+
| login | permission        |
+-------+-------------------+
| admin | IDMEF_VIEW        |
| admin | IDMEF_ALTER       |
| admin | USER_MANAGEMENT   |
| admin | COMMAND           |
| admin | INTRUSIVE_COMMAND |
+-------+-------------------+

I tried also to allow permission to anonymous users, but doesn't work:

+-----------+-------------------+
| login     | permission        |
+-----------+-------------------+
| admin     | IDMEF_VIEW        |
| admin     | IDMEF_ALTER       |
| admin     | USER_MANAGEMENT   |
| admin     | COMMAND           |
| admin     | INTRUSIVE_COMMAND |
| anonymous | IDMEF_VIEW        |
| anonymous | IDMEF_ALTER       |
| anonymous | USER_MANAGEMENT   |
| anonymous | COMMAND           |
| anonymous | INTRUSIVE_COMMAND |
+-----------+-------------------+

At the module_registry table I tried to unable the AnonymousSession to check if then prewikka asks me to introduce an user and password, but it doesn't (see the attached image).

+----------------------------------------------------------+---------+--------+---------+
| module                                                   | enabled | branch | version |
+----------------------------------------------------------+---------+--------+---------+
| prewikka                                                 |       1 | 5.0    | 0       |
| prewikka.dataprovider.idmef:IDMEFAlertProvider           |       1 | NULL   | NULL    |
| prewikka.dataprovider.idmef:IDMEFHeartbeatProvider       |       1 | NULL   | NULL    |
| prewikka.dataprovider.plugins.idmef:IDMEFAlertPlugin     |       1 | NULL   | NULL    |
| prewikka.dataprovider.plugins.idmef:IDMEFHeartbeatPlugin |       1 | NULL   | NULL    |
| prewikka.plugins.warning:Warning                         |       1 | NULL   | NULL    |
| prewikka.renderer.chartjs.bar:ChartJSBarPlugin           |       1 | NULL   | NULL    |
| prewikka.renderer.chartjs.timeline:ChartJSTimebarPlugin  |       1 | NULL   | NULL    |
| prewikka.renderer.chartjs:ChartJSPlugin                  |       1 | NULL   | NULL    |
| prewikka.session.anonymous.anonymous:AnonymousSession    |       0 | NULL   | NULL    |
| prewikka.views.about:About                               |       1 | NULL   | NULL    |
| prewikka.views.aboutplugin:AboutPlugin                   |       1 | NULL   | NULL    |
| prewikka.views.agents:AgentPlugin                        |       1 | NULL   | NULL    |
| prewikka.views.crontab:CrontabView                       |       1 | NULL   | NULL    |
| prewikka.views.filter.filter:FilterView                  |       1 | 5.0    | 0       |
| prewikka.views.idmefnav:IDMEFNav                         |       1 | NULL   | NULL    |
| prewikka.views.messagesummary:MessageSummary             |       1 | NULL   | NULL    |
| prewikka.views.usermanagement:UserManagement             |       1 | NULL   | NULL    |
+----------------------------------------------------------+---------+--------+---------+

I've checked that the prewikka user has right to access all the needed tables in mysql, but still, nothing.

prewikka_anonymous.PNG View - no requests for login data (17.7 KB)

RE: [prewikka] Multiple options not avaibale after installing prewikka - Added by Antoine LUONG 3 months ago

Hello,

You seem to be using a very old Prewikka database schema.
Please try again from an empty database.

Regards

RE: [prewikka] Multiple options not avaibale after installing prewikka - Added by Steven Shawn 3 months ago

Same problem.

It creates the following tables:


+-----------------------------+
| Tables_in_prewikka          |
+-----------------------------+
| Prewikka_Crontab            |
| Prewikka_Filter             |
| Prewikka_History_Query      |
| Prewikka_Module_Changed     |
| Prewikka_Module_Registry    |
| Prewikka_Session            |
| Prewikka_User_Configuration |
+-----------------------------+

But still not asking for password

RE: [prewikka] Multiple options not avaibale after installing prewikka - Added by Antoine LUONG 3 months ago

The current OSS version does not include an authentication module, though we may add it in the future.
For the time being, configuring a basic authentication with Apache could do the job.

Regards

RE: [prewikka] Multiple options not avaibale after installing prewikka - Added by Steven Shawn 3 months ago

Hello Antoine,

I configured a basic authentication with apache, but despite it asks for the user and passw before leting me access the prewikka interface, I'm still appearing as "anonymous". Can you specify how to do this process? or any other workaround to solve this issue?

Thank you!

Steven

    (1-6/6)