Project

General

Profile

Bug #121

500 Internal Server Error on Heartbeat page

Added by admin admin over 13 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
High
Target version:
Start date:
Due date:
% Done:

0%

Resolution:
duplicate

Description

This is with apache 2.0 and mod_python. Any heart beat page results in these errors in the logs.

[[PythonHandler]] prewikka.ModPythonHandler: Traceback (most recent call last):, referer: http://fakeserver.com/prelude/?view=alert_listing

[[PythonHandler]] prewikka.ModPythonHandler:   File "/usr/lib/python2.3/site-packages/mod_python/apache.py", line 299, in [[HandlerDispatch]]\n    result = object(req), referer: http://fakeserver.com/prelude/?view=alert_listing

[[PythonHandler]] prewikka.ModPythonHandler:   File "/usr/lib/python2.3/site-packages/prewikka/ModPythonHandler.py", line 73, in handler\n    core.process(request), referer: http://fakeserver.com/prelude/?view=alert_listing

[[PythonHandler]] prewikka.ModPythonHandler:   File "/usr/lib/python2.3/site-packages/prewikka/Core.py", line 297, in process\n    request.content = str(template), referer: http://fakeserver.com/prelude/?view=alert_listing

[[PythonHandler]] prewikka.ModPythonHandler:   File "/usr/lib/python2.3/site-packages/prewikka/templates/HTMLDocument.py", line 187, in +str+\n    def +str+(self): return self.respond(), referer: http://fakeserver.com/prelude/?view=alert_listing

[[PythonHandler]] prewikka.ModPythonHandler:   File "/usr/lib/python2.3/site-packages/prewikka/templates/HTMLDocument.py", line 172, in respond\n    +v = VFFSL(SL,"body",True) # <- $body, referer: http://fakeserver.com/prelude/?view=alert_listing

[[PythonHandler]] prewikka.ModPythonHandler:   File "/usr/lib/python2.3/site-packages/prewikka/templates/TopLayout.py", line 144, in body\n    +v = VFFSL(SL,"toplayout_content",True) # <- $toplayout_content, referer: http://fakeserver.com/prelude/?view=alert_listing

[[PythonHandler]] prewikka.ModPythonHandler:   File "/usr/lib/python2.3/site-packages/prewikka/templates/ClassicLayout.py", line 282, in toplayout_content\n    +v = VFFSL(SL,"main_content",True) # <- $main_content, referer: http://fakeserver.com/prelude/?view=alert_listing

[[PythonHandler]] prewikka.ModPythonHandler:   File "/usr/lib/python2.3/site-packages/prewikka/templates/MessageListing.py", line 215, in main_content\n    +v = VFFSL(SL,"message_fields",True) # <- $message_fields, referer: http://fakeserver.com/prelude/?view=alert_listing

[[PythonHandler]] prewikka.ModPythonHandler:   File "/usr/lib/python2.3/site-packages/prewikka/templates/HeartbeatListing.py", line 255, in message_fields\n    return +dummyTrans and trans.response().getvalue() or "", referer: http://fakeserver.com/prelude/?view=alert_listing

[[PythonHandler]] prewikka.ModPythonHandler:   File "/usr/lib/python2.3/site-packages/Cheetah/DummyTransaction.py", line 32, in getvalue\n    return _.join(outputChunks), referer: http://fakeserver.com/prelude/?view=alert_listing

[[PythonHandler]] prewikka.ModPythonHandler: [[TypeError]]: sequence item 1: expected string, int found, referer: http://fakeserver.com/prelude/?view=alert_listing

History

#1 Updated by Yoann VANDOORSELAERE over 13 years ago

  • Status changed from New to Closed
  • Resolution set to duplicate

Mark as duplicate of ticket #119.

#2 Updated by Yoann VANDOORSELAERE over 10 years ago

  • Project changed from PRELUDE SIEM to Prewikka
  • Category deleted (5)
  • Target version deleted (0.9.3)

Also available in: Atom PDF