Project

General

Profile

Bug #123

prewikka heartbeats page: exception

Added by almost 14 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
High
Target version:
Start date:
Due date:
% Done:

0%

Resolution:
duplicate

Description

Hi there,

get the following exception message of the DEBUG on the server (webserver prewikka-httpd) every time I access the "heartbeats" page by browser. I am using prewikka v0.9.2.

Maybe the same problem as reported in Ticket #121 ?
And is there a connection to the problem I posted at the mailing list ([prelude-user] Wrong sensor status in prewikka 0.9.2 ) ?

Thanks and Regards.
----

[DEBUG/QUERY] peer None:1554
[DEBUG/PROCESS_RENDER_VIEW] peer None:1554; user admin; view heartbeat_listing
----------------------------------------
Exception happened during processing of request from ('<IP>', 1554)
Traceback (most recent call last):
  File "/usr/lib/python2.4/SocketServer.py", line 463, in process_request_thread
    self.finish_request(request, client_address)
  File "/usr/lib/python2.4/SocketServer.py", line 254, in finish_request
    self.RequestHandlerClass(request, client_address, self)
  File "/usr/lib/python2.4/SocketServer.py", line 521, in +init+
    self.handle()
  File "/usr/lib/python2.4/BaseHTTPServer.py", line 314, in handle
    self.handle_one_request()
  File "/usr/lib/python2.4/BaseHTTPServer.py", line 308, in handle_one_request
    method()
  File "/usr/bin/prewikka-httpd", line 114, in do_GET
    self._processDynamic(cgi.parse_qs(self.path[2:]))
  File "/usr/bin/prewikka-httpd", line 77, in _processDynamic
    self.server.core.process(self)
  File "/usr/lib/python2.4/site-packages/prewikka/Core.py", line 297, in process
    request.content = str(template)
  File "/usr/lib/python2.4/site-packages/prewikka/templates/HTMLDocument.py", line 187, in +str+
    def +str+(self): return self.respond()
  File "/usr/lib/python2.4/site-packages/prewikka/templates/HTMLDocument.py", line 172, in respond
    +v = VFFSL(SL,"body",True)
  File "/usr/lib/python2.4/site-packages/prewikka/templates/TopLayout.py", line 144, in body
    +v = VFFSL(SL,"toplayout_content",True)
  File "/usr/lib/python2.4/site-packages/prewikka/templates/ClassicLayout.py", line 282, in toplayout_content
    +v = VFFSL(SL,"main_content",True)
  File "/usr/lib/python2.4/site-packages/prewikka/templates/MessageListing.py", line 215, in main_content
    +v = VFFSL(SL,"message_fields",True)
  File "/usr/lib/python2.4/site-packages/prewikka/templates/HeartbeatListing.py", line 255, in message_fields
    return +dummyTrans and trans.response().getvalue() or "" 
  File "/usr/lib/python2.4/site-packages/Cheetah/DummyTransaction.py", line 32, in getvalue
    return _.join(outputChunks)
[[TypeError]]: sequence item 1: expected string, int found
----------------------------------------

History

#1 Updated by Yoann VANDOORSELAERE almost 14 years ago

  • Status changed from New to Closed
  • Resolution set to duplicate

Mark as duplicate of ticket #119.

#2 Updated by Yoann VANDOORSELAERE over 10 years ago

  • Project changed from PRELUDE SIEM to Prewikka
  • Category deleted (5)
  • Target version deleted (0.9.3)

Also available in: Atom PDF