Project

General

Profile

Bug #150

A number of issues with command line options

Added by almost 13 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
Due date:
% Done:

0%

Resolution:
fixed

Description

i ran into a number of problems when trying to set up a prelude-manager under a different profile name. some options cause problems or must be used differently than described.

1. the usage of prelude-manager says -prelude --profile=ARG but that does not work. Removing the =_ and writing _--prelude --profile ARG works ok.
2. using --config=ARG gives a warning: Invalid option - "config" (0). but the specified config-file seems to be used anyway.
3. using two options from the --prelude subcategory without the category gives a segfault. adding another --prelude (i.e. saying --prelude --profile foo --prelude --heartbeat-interval=60 instead of --prelude --profile foo --heartbeat-interval=60 works ok). for the other categories, you can give multiple categroy-options per category.
4. --prelude --profile foo (and maybe others) only works if specified before -d

some of this behaviour may be intended, but at least it should be documented...

there could be more issues with the command-line option handling. i did not test this systematically. these are just the ones i ran into...

this was done with prelude-manager-0.9.4.1 and libprelude-0.9.7.2

History

#1 Updated by Yoann VANDOORSELAERE almost 13 years ago

  • Status changed from New to Assigned

Reword description for readability. Reword summary since this is not prelude-manager specific.

#2 Updated by Yoann VANDOORSELAERE almost 13 years ago

Please try changeset r8171, which should fix point 1 and 3. I am not able to reproduce point 4, can you confirm it happen with the patch applied ? Point 2 will be a separate fix.

#3 Updated by Yoann VANDOORSELAERE almost 13 years ago

  • Status changed from Assigned to Closed
  • Resolution set to fixed

Marking as closed. Please open a separate ticket for point 4 if you are still able to reproduce it with r8171 applied.

#4 Updated by Yoann VANDOORSELAERE almost 10 years ago

  • Project changed from PRELUDE SIEM to Libprelude
  • Category deleted (1)
  • Target version deleted (0.9.8)

Also available in: Atom PDF