Project

General

Profile

Bug #165

undefined reference to yy_delete_buffer, yy_scan_string and yylex

Added by almost 13 years ago. Updated almost 10 years ago.

Status:
Closed
Priority:
Normal
Target version:
Start date:
Due date:
% Done:

0%

Resolution:
worksforme

Description

Hi,

I am trying to build libprelude svn trunk head on FC5 and am receiving the following message:

$ make distclean;./autogen.sh; ./configure; make
[...]
gcc -g -O2 -pthread -Wall -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations -Wbad-function-cast -Wcast-qual -Wcast-align -Wnested-externs -Wunused -pthread -o .libs/prelude-adduser prelude-adduser.o server.o tls-register.o  ../src/.libs/libprelude.so -lgnutls -lgcrypt -lgpg-error -lrt -ldl
../src/.libs/libprelude.so: undefined reference to @yy_delete_buffer'
../src/.libs/libprelude.so: undefined reference to @yy_scan_string'
../src/.libs/libprelude.so: undefined reference to @yylex'
collect2: ld returned 1 exit status
maker2: *** [prelude-adduser] Error 1
maker2: Leaving directory @/usr/local/src/libprelude/prelude-adduser'
maker1: *** [all-recursive] Error 1
maker1: Leaving directory @/usr/local/src/libprelude'
make: *** [all] Error 2

Is there anything I am missing?

History

#1 Updated by Yoann VANDOORSELAERE over 12 years ago

What version of Flex are you using? Does it happen with official released tarball?
What happen if you remove the included idmef-criteria-string.lex.[ch] and idmef-criteria-string.yac.[ch] ?

#2 Updated by over 12 years ago

$ flex --version
flex version 2.5.4

I eventually got this working with "libprelude-trunk-latest" downloaded on July 13th 2006. I guess I'm all set now :)

#3 Updated by Yoann VANDOORSELAERE over 12 years ago

  • Status changed from New to Closed
  • Resolution set to worksforme

Probably a file generation problem due to a bug in your version of Flex or an invalid timestamp on the generated files. Since you confirmed that everything work as expected with released tarball, I'm marking this bug as closed. Please reopen if needed.

#4 Updated by Yoann VANDOORSELAERE almost 10 years ago

  • Project changed from PRELUDE SIEM to Libprelude
  • Category deleted (1)
  • Target version deleted (0.9.11)

Also available in: Atom PDF