Project

General

Profile

Bug #322

prelude-admin list segfaults

Added by over 10 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
Start date:
Due date:
% Done:

0%

Resolution:
duplicate

Description

Running "prelude-admin list" segfaults instead of printing a list. valgrind out put shows:

==2824== Invalid read of size 8
==2824==    at 0x4E5DA78: prelude_client_profile_get_profile_dirname (in /usr/lib64/libprelude.so.2.17.0)
==2824==    by 0x408E06: list_cmd (prelude-admin.c:2020)
==2824==    by 0x40854A: main (prelude-admin.c:2212)
==2824==  Address 0x10 is not stack'd, malloc'd or (recently) free'd
==2824==
==2824== Process terminating with default action of signal 11 (SIGSEGV)
==2824==  Access not within mapped region at address 0x10
==2824==    at 0x4E5DA78: prelude_client_profile_get_profile_dirname (in /usr/lib64/libprelude.so.2.17.0)
==2824==    by 0x408E06: list_cmd (prelude-admin.c:2020)
==2824==    by 0x40854A: main (prelude-admin.c:2212)

This is libprelude-0.9.21.1

log.txt View - valgrind output (1.02 KB) , 10/11/2008 09:09 PM

History

#1 Updated by Yoann VANDOORSELAERE over 10 years ago

  • Status changed from New to Closed
  • Resolution set to duplicate

Mark as duplicate of #320.

#2 Updated by Yoann VANDOORSELAERE about 10 years ago

  • Project changed from PRELUDE SIEM to Libprelude
  • Category deleted (1)
  • Target version deleted (92)

Also available in: Atom PDF