Project

General

Profile

Bug #36

Introduce a backward compatible version of 'classic' database plugin

Added by Yoann VANDOORSELAERE almost 15 years ago. Updated about 10 years ago.

Status:
Closed
Priority:
Normal
Assignee:
-
Target version:
-
Start date:
Due date:
% Done:

0%

Resolution:
wontfix

Description

A version of classic compatible with existing 0-8 databases should be re-introduced in libpreludedb. This plugin don't have to support writing to the database as some of the recent IDMEF structure changes make this impossible. It would be interesting to add two new libpreludedb plugin flags: a capability flags (read/write), plus a version flags (classic 0.8/0.9).

History

#1 Updated by Yoann VANDOORSELAERE over 14 years ago

  • Status changed from New to Closed
  • Resolution set to wontfix

Backward compatibility on schema modification is possible however since from 0-8 to 0-9 the IDMEF structure evolved a lot, and since frontends are only aware of newer IDMEF version, there is no way to maintain compatibility at this level. Thus making a backward compatibility plugin for 0-8 kind of database is not constructive since frontend won't be able to query theses data anyway.

#2 Updated by Yoann VANDOORSELAERE about 10 years ago

  • Project changed from PRELUDE SIEM to LibpreludeDB
  • Category deleted (2)

Also available in: Atom PDF