Project

General

Profile

Support #388

Can't install Prelude-Manager

Added by Chris Hager over 8 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Start date:
12/17/2010
Due date:
% Done:

100%

Resolution:

Description

I'm trying to get Prelude Manager installed on a 64 bit Ubuntu server (Ubuntu 10.04.1 LTS) using only the Ubuntu packages, and I keep running into a wall. The others (libprelude, libpreludedb, etc) seem to install okay.When I first tried to install prelude-manager, I got an error stating that the prelude-manager.conf file couldn't be written to /etc/prelude-manager/. I manually copied it from /etc/dbconfig-common/ and tried again. This time I get the following, and cannot go any further (the file tls.conf does not exist anywhere in my file system). I've been googling the issue for two days and cannot find any solution:

root@hids:/etc/prelude# apt-get install prelude-manager
Reading package lists... Done
Building dependency tree
Reading state information... Done
prelude-manager is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 41 not upgraded.
1 not fully installed or removed.
After this operation, 0B of additional disk space will be used.
Setting up prelude-manager (0.9.15-4) ...
dbconfig-common: writing config to /etc/dbconfig-common/prelude-manager.conf
17 Dec 14:31:49 (process:5434) WARNING: config-file: could not open /etc/prelude/default/tls.conf: could not open '/etc/prelude/default/tls.conf' for reading: No such file or directory.
dpkg: error processing prelude-manager (--configure):
subprocess installed post-installation script returned error exit status 1
Errors were encountered while processing:
prelude-manager
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@hids:/etc/prelude#

Additionally, I just tried the debian package prelude-manager_1.0.0-1_amd64.deb and I get the exact same error. I'm not a development person, and I'm not a linux guru, so forgive me if I'm going about getting support in the wrong manner.

History

#1 Updated by Chris Hager over 8 years ago

I was able to get everything installed and running successfully by removing all Prelude apps, upgrading my server to Ubuntu 10.10, and then reinstalling them using. So, no longer an issue that I need support with, although there is apparently a bug for Ubuntu 10.04 users.

#2 Updated by Andrew Rojek over 8 years ago

Hey Chris,

Try building and installing version 1.0.1.

I also had problems with 1.0.0 but
everything seems to have been solved
with the latest release.

Also you might want to double check
that you are installing the package with
'root' user priveleges, especially into etc.
Other wise you could use the --sysconfdir
or --prefix option when you are configuring
to re-divert the install location.

A.

#3 Updated by Francois POIROTTE over 7 years ago

  • Status changed from New to Closed
  • Assignee set to Francois POIROTTE
  • Target version changed from 0.9.15 to 1.0.1
  • % Done changed from 0 to 100

Probl

#4 Updated by Thomas ANDREJAK almost 4 years ago

  • Target version changed from 1.0.1 to Prelude OSS 1.0.1

Also available in: Atom PDF