Project

General

Profile

Bug #46

lml rely on un-portable strptime behavior.

Added by Yoann VANDOORSELAERE about 15 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
Start date:
Due date:
% Done:

0%

Resolution:
fixed

Description

It is not specified whether strptime will modify the member of a localtime struct when theses member are not matched by the format string. This, for example result in a bug on Solaris 7.

History

#1 Updated by Sebastien Tricaud almost 15 years ago

According to http://www.ethereal.com/lists/ethereal-dev/200201/msg00406.html

"Well, building with just USE_XOPEN, and without _XOPEN_SOURCE or
+EXTENSIONS
, seemed to work on Solaris 8, DU 4.0, and HP-UX 11.00 -
no problem with "strptime()"."

#2 Updated by Yoann VANDOORSELAERE almost 15 years ago

The problem is not with the strptime() declaration, but rather that the function will reset the tm structure to 0 before filling it, which break the reported time. This behavior is implementation dependant.

#3 Updated by Yoann VANDOORSELAERE over 14 years ago

Still waiting more comment from an user with a machine to experiment this on. Setting tm_isdst to -1 seem to partially fix the problem, through this is definitly not a clean solution.

#4 Updated by Yoann VANDOORSELAERE over 14 years ago

Had a Solaris OS to experience this on. Fixed in changeset r6308.

#5 Updated by Yoann VANDOORSELAERE over 14 years ago

  • Status changed from New to Closed
  • Resolution set to fixed

#6 Updated by Yoann VANDOORSELAERE over 10 years ago

  • Project changed from PRELUDE SIEM to Prelude-LML
  • Category deleted (4)

Also available in: Atom PDF