Project

General

Profile

Bug #295

Ocasional LUA error message

Added by Yoann VANDOORSELAERE over 11 years ago. Updated over 10 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
Start date:
Due date:
% Done:

0%

Resolution:
fixed

Description

ERROR: LUA error on 'firewall': /etc/prelude-correlator/lua-rules/firewall.lua:35: attempt to index local 'result' (a nil value). (lua.c:148 lua_run)

This seems to happen when using the IDMEF:get() method using 2 wiki:IDMEFPath arguments (1, 3 or more work).

return-table-on-multipath.diff View - Always return a table (with NULL values) when retrieving empty multipath (703 Bytes) Yoann VANDOORSELAERE, 07/01/2008 10:43 AM

History

#1 Updated by Yoann VANDOORSELAERE over 11 years ago

r10624 should fixes this issue.

#2 Updated by over 11 years ago

The problem still occurs with patches applied and when prelude-manager processes AVC alerts from the auditd sensor.

#3 Updated by Yoann VANDOORSELAERE over 11 years ago

Replying to [comment:3 ]:

The problem still occurs with patches applied and when prelude-manager processes AVC alerts from the auditd sensor.

Could you try return-table-on-multipath.diff and tell me whether there is no regression?

#4 Updated by over 11 years ago

I still get the problem with the 2 patches applied. Was I supposed to delete the first patch?

#5 Updated by over 11 years ago

Re-tested this and it looks like it is indeed fixed with both patches applied. Thanks!

#6 Updated by Yoann VANDOORSELAERE over 11 years ago

  • Status changed from New to Closed
  • Resolution set to fixed

(In r10627) Always return a table when retrieving multiple path (even
with empty path). Fix #295.

#7 Updated by Yoann VANDOORSELAERE over 11 years ago

(In r10627) Always return a table when retrieving multiple path (even
with empty path). Fix #295.

#8 Updated by Yoann VANDOORSELAERE over 11 years ago

(In r10627) Always return a table when retrieving multiple path (even
with empty path). Fix #295.

#9 Updated by Yoann VANDOORSELAERE over 11 years ago

(In r10627) Always return a table when retrieving multiple path (even
with empty path). Fix #295.

#10 Updated by Yoann VANDOORSELAERE over 11 years ago

(In r10627) Always return a table when retrieving multiple path (even
with empty path). Fix #295.

#11 Updated by Yoann VANDOORSELAERE over 11 years ago

(In r10627) Always return a table when retrieving multiple path (even
with empty path). Fix #295.

#12 Updated by Yoann VANDOORSELAERE over 11 years ago

(In r10627) Always return a table when retrieving multiple path (even
with empty path). Fix #295.

#13 Updated by Yoann VANDOORSELAERE over 11 years ago

(In r10627) Always return a table when retrieving multiple path (even
with empty path). Fix #295.

#14 Updated by Yoann VANDOORSELAERE over 11 years ago

(In r10627) Always return a table when retrieving multiple path (even
with empty path). Fix #295.

#15 Updated by Yoann VANDOORSELAERE over 11 years ago

(In r10627) Always return a table when retrieving multiple path (even
with empty path). Fix #295.

#16 Updated by Yoann VANDOORSELAERE over 11 years ago

(In r10627) Always return a table when retrieving multiple path (even
with empty path). Fix #295.

#17 Updated by Yoann VANDOORSELAERE over 11 years ago

(In r10627) Always return a table when retrieving multiple path (even
with empty path). Fix #295.

#18 Updated by Yoann VANDOORSELAERE over 11 years ago

(In r10627) Always return a table when retrieving multiple path (even
with empty path). Fix #295.

#19 Updated by Yoann VANDOORSELAERE over 10 years ago

  • Project changed from PRELUDE SIEM to Prelude Correlator
  • Category deleted (11)

Also available in: Atom PDF