Project

General

Profile

Bug #386

libprelude build failure with libtool 2.4

Added by Roman Khimov almost 9 years ago. Updated almost 4 years ago.

Status:
Closed
Priority:
Normal
Start date:
11/07/2010
Due date:
% Done:

0%

Resolution:
fixed

Description

Re-libtoolized (with libtool 2.4) libprelude fails to build with: =======================================================
In file included from prelude-plugin.c:56:0:
/include/prelude-plugin.h:66:20: error: conflicting types for 'lt__PROGRAM__LTX_preloaded_symbols'
/oe/build-angstrom-next/angstrom-dev/sysroots/armv7a-angstrom-linux-gnueabi/usr/include/ltdl.h:106:36: note: previous declaration of 'lt__PROGRAM__LTX_preloaded_symbols' was here
make4: *** [prelude-plugin.lo] Error 1 =======================================================
The problem is that libtool 2.4 changed lt__PROGRAM__LTX_preloaded_symbols definition to

extern LT_DLSYM_CONST lt_dlsymlist lt__PROGRAM__LTX_preloaded_symbols[];

but there is no easy way to find its version to fix it properly, so attached is a temporary hack to make at least libprelude itself compile.

fix-ltdl-hack.patch View - workaround for the problem (889 Bytes) Roman Khimov, 11/07/2010 09:40 PM

History

#1 Updated by Jean-Charles ROGEZ about 7 years ago

  • Project changed from PRELUDE SIEM to Libprelude

#2 Updated by Jean-Charles ROGEZ almost 6 years ago

  • Target version set to 124

#3 Updated by Antoine LUONG about 5 years ago

  • Status changed from New to Resolved
  • Assignee set to Yoann VANDOORSELAERE
  • Target version changed from 124 to 126
  • Resolution set to fixed

#4 Updated by Thomas ANDREJAK almost 4 years ago

  • Status changed from Resolved to Closed
  • Target version changed from 126 to Prelude OSS 1.2.5

Also available in: Atom PDF