Project

General

Profile

Bug #760

LibPrelude 3.0 : Python and Ruby bindings

Added by Thomas ANDREJAK over 3 years ago. Updated about 3 years ago.

Status:
Closed
Priority:
Normal
Start date:
05/30/2016
Due date:
% Done:

0%

Resolution:

Description

In the libprelude 3.0, we have generate bindings using SWIG 3.0.6.

But to be able to compile with latest Python 3.5 and latest Ruby 2.1, we have to use at least SWIG 3.0.7 or newer.

We will patch this on the next version. Here is a patch for example.

ruby_swig.patch View (1.21 KB) Thomas ANDREJAK, 05/30/2016 07:19 AM

python_swig.patch View (58.3 KB) Thomas ANDREJAK, 07/07/2016 11:41 PM

History

#2 Updated by Thomas ANDREJAK about 3 years ago

  • Status changed from New to Closed
  • Target version set to Prelude OSS 3.1.0

Also available in: Atom PDF