Project

General

Profile

Suricata compilation failed with --enable-prelude

Added by Pierre R 8 days ago

Hello,

I have a issue with installation suricata with --enable-prelude option.

When I execute this command "./configure --enable-prelude --with-libprelude-prefix=/usr CC="gcc -std=gnu99"", the compilation start and at the libprelude level, I have this error :

checking for libprelude-config... /usr/bin/libprelude-config
checking for libprelude - version >= 0.9.9... no
*** Could not run libprelude test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means LIBPRELUDE was incorrectly installed
*** or that you have moved LIBPRELUDE since it was installed. In the latter case, you
*** may want to edit the libprelude-config script: /usr/bin/libprelude-config
configure: error: Cannot find libprelude: Is libprelude-config in the path?

My OS is CentOS 8 and I have follow the Prelude Documentation. I have try to fix this problem, but for the moment I could not succeed to find the solution and I'm a little lost ;) .

Anybody can help my ? Thanks you for your help :) !

Pierre


Replies (7)

RE: Suricata compilation failed with --enable-prelude - Added by Thomas ANDREJAK 8 days ago

Hello

Can you give me more details :
- What is the version of suricata ?
- Did you install libprelude-devel ?
- Can you try to configure with just "./configure --enable-prelude" ?

Regards

Thomas

RE: Suricata compilation failed with --enable-prelude - Added by Pierre R 8 days ago

Thanks for your help :) !

Suricata version is 5.0.3, I have installed libprelude-devel and I tried "./configure --enable-prelude" and I get the same result.

Regards,

Pierre

RE: Suricata compilation failed with --enable-prelude - Added by Thomas ANDREJAK 8 days ago

Hello

how did you install libprelude-devel? by rpm?

Because the configure does not find libprelude-devel

Regards

RE: Suricata compilation failed with --enable-prelude - Added by Pierre R 8 days ago

Yes, I have installed libprelude-devel version 5.1.1 by rpm with Epel repository.

Do I have to use "libprelude-5.1.0.tar.gz" ?

Regards,

Pierre

RE: Suricata compilation failed with --enable-prelude - Added by Thomas ANDREJAK 8 days ago

Hello

You do not have to use the .tar.gz

I don't know what happens with your OS because it is working upstream : https://koji.fedoraproject.org/koji/taskinfo?taskID=44793986

If you just need suricata with prelude support, you can install the rpm.

Regards

Thomas

RE: Suricata compilation failed with --enable-prelude - Added by Pierre R 8 days ago

Okay, so I just need to use .rpm and it will work with Prelude ?

I thought I needed to compile Suricata with "--enable-prelude" option in order to use Prelude with Suricata and that the RPM did not work because it was not compiled with this option.

Regards,

Pierre

RE: Suricata compilation failed with --enable-prelude - Added by Pierre R 7 days ago

Hi,

It works perfectly now ! Thank you for your support and your explanations :) .

Regards,

Pierre

    (1-7/7)