Project

General

Profile

Plan to use python3 instead of python2

Added by Andrew Goldy about 2 months ago

Hello!

Do you plan to use python3 in prewikka&prelude-correlator in the future?
Python2 is dropped off almost every OS, therefore prewikka becomes unusable.


Replies (3)

RE: Plan to use python3 instead of python2 - Added by Francois POIROTTE about 2 months ago

Hello,

prewikka & prelude-correlator already support Python 3 since version 5.2.
Most Linux distributions already ship this version and so, unless you are using an uncommon distribution or an old version, it should already be possible to use Prelude with Python 3 on your system.

However please note that some distributions provide the Python 3 packages under a different name (e.g. the Python 3 package for Prewikka is called "python3-prewikka" rather than "prewikka" on CentOS 8), so make sure to check your distribution's repositories for the proper name to use.

Best regards

RE: Plan to use python3 instead of python2 - Added by Andrew Goldy about 1 month ago

Hello,

After upgrading from debian 10 to debian 11 which drops off python2, prewikka is not working anymore.
Prewikka version 5.2 was built from source, not from the repo.
The install file says

Build requires:

- python >= 2.7 (not python 3.x)
- python-babel
- python-lesscpy
- python-setuptools

Correlator also not working with python3.

RE: Plan to use python3 instead of python2 - Added by Francois POIROTTE about 1 month ago

Hello,

I think the installation instructions haven't been updated yet, but the code should work on Python 3, just give it a try.
Also, unless you have good reasons not to, I would recommend using the official Debian packages. That way it is easier to keep track of updates, dependencies, etc.

Regards,
François

    (1-3/3)