Project

General

Profile

Bug #373

could not resolve 127.0.0.1: Address family for hostname not supported

Added by Pierre Chifflier about 14 years ago. Updated about 8 years ago.

Status:
Closed
Priority:
Normal
Target version:
-
Start date:
03/23/2010
Due date:
% Done:

0%

Resolution:

Description

When booting on a host without any IP address (/etc/resolv.conf is empty):

# prelude-admin register prelude-lml "idmef:w" 127.0.0.1 --uid 0 --gid 0 --passwd secret
could not resolve 127.0.0.1: Address family for hostname not supported

My guess: prelude-admin is trying to resolv 127.0.0.1 (which causes the error), while it could take it directly as an ip address

libprelude 1.0.0

History

#1 Updated by Pierre Chifflier over 13 years ago

I found the solution (not the entire explanation of the problem): it was caused by IPv6

Setting

sysctl -w net.ipv6.conf.all.disable_ipv6=1

During the boot sequence solves the problem.

The bug is not related to Prelude, so feel free to close it.

#2 Updated by Francois POIROTTE over 12 years ago

  • Status changed from New to Assigned
  • Assignee set to Francois POIROTTE

Je pense qu'il faut jeter un coup d'

#3 Updated by Thomas ANDREJAK about 8 years ago

  • Status changed from Assigned to Closed

Issue on client side.

Also available in: Atom PDF