Project

General

Profile

Bug #515

libprelude does not compile with gcc 4.6

Added by Luiz Angelo Daros de Luca about 7 years ago. Updated over 3 years ago.

Status:
Closed
Priority:
Normal
Assignee:
Start date:
08/06/2012
Due date:
% Done:

0%

Resolution:

Description

Hello,

#include <stddef.h> is missing at bindings/c++/include/prelude.hxx. This patch adds the missing header
which fixes the compilation for gcc>=4.6. I don't know if it breaks older gcc versions.

libprelude-1.0.0-gcc46.patch View (511 Bytes) Luiz Angelo Daros de Luca, 08/06/2012 10:20 PM

History

#1 Updated by Jean-Charles ROGEZ about 7 years ago

  • Status changed from New to Assigned
  • Assignee set to Antoine LUONG

Thanks for the patch. May be a similar issue as #504.

#2 Updated by Jean-Charles ROGEZ about 7 years ago

  • Project changed from PRELUDE SIEM to Libprelude
  • Category deleted (generic)

#3 Updated by Antoine LUONG about 7 years ago

The patch doesn't seem to pose a problem with gcc 4.4.

#4 Updated by Jean-Charles ROGEZ about 6 years ago

  • Target version changed from 117 to 124

#5 Updated by Thomas ANDREJAK almost 4 years ago

  • Target version changed from 124 to Prelude OSS 3.0.0

#6 Updated by Thomas ANDREJAK over 3 years ago

  • Target version changed from Prelude OSS 3.0.0 to Prelude OSS 3.1.0

#7 Updated by Thomas ANDREJAK over 3 years ago

  • Status changed from Assigned to Closed

It works now

Also available in: Atom PDF